Skip to content

Migrate plugin to built-in Kotlin #656

Closed

Description

@guilhermeagostinelli

I am using intercom_flutter in my Flutter app.

Starting with Android Gradle Plugin (AGP) 9.0,
support for applying the Kotlin Gradle Plugin (KGP) has been removed.
Because this plugin applies KGP,
it causes a compilation error that prevents my app from building.
Flutter issue #181383
includes an example of the error.

Flutter has temporarily added support to allow KGP
while apps and plugins migrate to AGP 9.0 or later,
but this support will be removed in a future version of Flutter.

Please migrate this plugin to use built-in Kotlin to
ensure your plugin users can successfully
build their apps in future versions of Flutter.

Here is the Flutter
migration guide for plugin authors.

Activity

  1. self-assigned this
    on Aug 31, 2026
  2. deepak786 commented on Sep 1, 2026

    @deepak786
    Owner

    Fixed in intercom_flutter: ^9.6.25. The plugin applies the Kotlin Gradle Plugin only when AGP built-in Kotlin is not active, so AGP 9 apps can build with android.builtInKotlin true or false. A full cutover (never apply KGP, Flutter 3.44+) can follow later.


    If you find this package helpful, you can support the development by:

    Buy Me A Coffee
    PayPal

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment

Metadata

Metadata

Assignees

Labels

Projects

No projects

    Milestone

    No milestone

    Relationships

    None yet

    Development

    No branches or pull requests

    Issue actions