Repository navigation
chore(deps-dev): bump @babel/core from 7.29.7 to 8.0.7 - #19
dependabot[bot] wants to merge 1 commit into
Conversation
Bumps [@babel/core](https://github.com/babel/babel/tree/HEAD/packages/babel-core) from 7.29.7 to 8.0.7. - [Release notes](https://github.com/babel/babel/releases) - [Changelog](https://github.com/babel/babel/blob/main/CHANGELOG.md) - [Commits](https://github.com/babel/babel/commits/v8.0.7/packages/babel-core) --- updated-dependencies: - dependency-name: "@babel/core" dependency-version: 8.0.7 dependency-type: direct:development update-type: version-update:semver-major ... Signed-off-by: dependabot[bot] <support@github.com>
🔵 Tier A · Mergeable after minor fixes
This change upgrades the direct Babel compiler dependency to 8.0.7 and refreshes the npm lockfile, which retains Babel 7 copies for Expo and React Native packages that still require it.
Note Not approving while a bug finding is open: Align the supported Node range with Babel 8
Fix with agent prompt### Issue 1
package.json:55
**Align the supported Node range with Babel 8**
Babel 8.0.7 declares Node `^22.18.0 || >=24.11.0` in the refreshed lockfile, but this project still advertises Node 22.13+ and 24.3+ in `engines` and the README. Users on those lower versions now install an unsupported Babel runtime (and `npm ci` fails if `engine-strict` is enabled); please keep Babel on v7 or raise the documented Node minimums.
---
For each issue above, determine whether it is valid and should be fixed. If so, fix it directly.📂 Walkthrough · 2
Reviewed |
| }, | ||
| "devDependencies": { | ||
| "@babel/core": "^7.29.7", | ||
| "@babel/core": "^8.0.7", |
There was a problem hiding this comment.
Align the supported Node range with Babel 8
Babel 8.0.7 declares Node ^22.18.0 || >=24.11.0 in the refreshed lockfile, but this project still advertises Node 22.13+ and 24.3+ in engines and the README. Users on those lower versions now install an unsupported Babel runtime (and npm ci fails if engine-strict is enabled); please keep Babel on v7 or raise the documented Node minimums.
Prompt To Fix With AI
This is a comment left during a code review.
Path: package.json
Line: 55
Comment:
**Align the supported Node range with Babel 8**
Babel 8.0.7 declares Node `^22.18.0 || >=24.11.0` in the refreshed lockfile, but this project still advertises Node 22.13+ and 24.3+ in `engines` and the README. Users on those lower versions now install an unsupported Babel runtime (and `npm ci` fails if `engine-strict` is enabled); please keep Babel on v7 or raise the documented Node minimums.
---
For each issue above, determine whether it is valid and should be fixed. If so, fix it directly.🟡 Minor · bug · Reply if this doesn't apply.
|
Superseded by #23. |
Bumps @babel/core from 7.29.7 to 8.0.7.
Release notes
Sourced from @babel/core's releases.
... (truncated)
Changelog
Sourced from @babel/core's changelog.
... (truncated)
Commits
1fc0073v8.0.7d23b2fdfix(core): createConfigItem allows cb as 2nd arg (#18254)fd66590chore: upgrade verkit to v0.5.0 and obug to v3.0.0 (#18248)9e408d6v8.0.6753bedfRemove unused internal exports (#18235)e80c9acbuild: do not emit sourcemap in production build (#18231)8b01fecEnforce usage of Yarn catalog for reused dependencies (#18236)0d8ed70v8.0.54cea20dUse built-in glob in Node.js (#18097)1eac448refactor: replacesemverwithverkit(#18145)Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting
@dependabot rebase.Dependabot commands and options
You can trigger Dependabot actions by commenting on this PR:
@dependabot rebasewill rebase this PR@dependabot recreatewill recreate this PR, overwriting any edits that have been made to it@dependabot show <dependency name> ignore conditionswill show all of the ignore conditions of the specified dependency@dependabot ignore this major versionwill close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)@dependabot ignore this minor versionwill close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)@dependabot ignore this dependencywill close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)