Repository navigation
chore(deps): bump node-appwrite from 8.2.0 to 31.0.0 in /functions/upvoteProject - #81
Conversation
Bumps [node-appwrite](https://github.com/appwrite/sdk-for-node) from 8.2.0 to 31.0.0. - [Release notes](https://github.com/appwrite/sdk-for-node/releases) - [Changelog](https://github.com/appwrite/sdk-for-node/blob/main/CHANGELOG.md) - [Commits](appwrite/sdk-for-node@8.2.0...31.0.0) --- updated-dependencies: - dependency-name: node-appwrite dependency-version: 31.0.0 dependency-type: direct:production update-type: version-update:semver-major ... Signed-off-by: dependabot[bot] <support@github.com>
🟡 Tier B · Needs changes before merging
This updates the
Fix with agent prompt### Issue 1
functions/upvoteProject/package.json:13
**SDK 31 requires a newer Node runtime**
`node-appwrite` 31 declares `engines.node >=20`, but this function is configured with the `node-16.0` runtime in `appwrite.config.json`. That leaves the deployed function running the SDK on an unsupported Node version and can cause runtime failures; update the function runtime along with this dependency bump.
---
For each issue above, determine whether it is valid and should be fixed. If so, fix it directly.📂 Walkthrough · 1
Reviewed |
| "license": "ISC", | ||
| "dependencies": { | ||
| "node-appwrite": "^8.0.0" | ||
| "node-appwrite": "^31.0.0" |
There was a problem hiding this comment.
SDK 31 requires a newer Node runtime
node-appwrite 31 declares engines.node >=20, but this function is configured with the node-16.0 runtime in appwrite.config.json. That leaves the deployed function running the SDK on an unsupported Node version and can cause runtime failures; update the function runtime along with this dependency bump.
Prompt To Fix With AI
This is a comment left during a code review.
Path: functions/upvoteProject/package.json
Line: 13
Comment:
**SDK 31 requires a newer Node runtime**
`node-appwrite` 31 declares `engines.node >=20`, but this function is configured with the `node-16.0` runtime in `appwrite.config.json`. That leaves the deployed function running the SDK on an unsupported Node version and can cause runtime failures; update the function runtime along with this dependency bump.
---
For each issue above, determine whether it is valid and should be fixed. If so, fix it directly.🟠 Major · bug · Reply if this doesn't apply.
Bumps node-appwrite from 8.2.0 to 31.0.0.
Release notes
Sourced from node-appwrite's releases.
... (truncated)
Changelog
Sourced from node-appwrite's changelog.
... (truncated)
Commits
3725f1cfeat: SDK update for version 31.0.0 (#179)13dbe4aMerge pull request #178 from appwrite/devf646a57docs: refresh README3ffbdebMerge commit 'a8e771af9014c509e9f802c7320451e7fa0936e6' into dev320249dMerge pull request #177 from appwrite/deva8e771afeat: SDK update for the 2.5.x majors47f77d1Merge remote-tracking branch 'origin/dev' into dev6a35b33feat: SDK update for the 2.5.x majors698ec7eMerge remote-tracking branch 'origin/dev' into dev013085cfeat: SDK update for the 2.5.x majorsMaintainer changes
This version was pushed to npm by GitHub Actions, a new releaser for node-appwrite since your current version.
Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting
@dependabot rebase.Dependabot commands and options
You can trigger Dependabot actions by commenting on this PR:
@dependabot rebasewill rebase this PR@dependabot recreatewill recreate this PR, overwriting any edits that have been made to it@dependabot show <dependency name> ignore conditionswill show all of the ignore conditions of the specified dependency@dependabot ignore this major versionwill close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)@dependabot ignore this minor versionwill close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)@dependabot ignore this dependencywill close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)